Experience Exchange Sever

January 22, 2010

POP3/IMAP4 service wont start after E2k7 SP1 Update

Filed under: Exchange 2007, Pop/Imap — vijayarelangovan @ 9:37 pm

Issue:

Microsoft Exchange IMAP4/POP3 service does not start after installation/attempt install of SP1 Exchange server 2007, Additionally the following events are logged in the Application Log:

Event ID: 1000
Source : NET Runtime 2.0 Error Reporting
Type: Error
Description
Faulting application microsoft.exchange.imap4service.exe, version 8.1.278.2, stamp
481f7fea, faulting module kernel32.dll, version 5.2.3790.4062, stamp 462643a7,debug
0, fault address 0x000000000000dd10.

Event ID: 7009
Event Source: Service Control Manager
Event Type: Error
Description:
Timeout (30000 milliseconds) waiting for the Microsoft Exchange POP3 service to connect.

Cause:

The following dll files could be corrupted as a result of unsuccessful install of SP1

Microsoft.Exchange.imap4.exe.config
Microsoft.Exchange.imap4service.exe.config
Microsoft.Exchange.imap4.exe.config.bak
Microsoft.Exchange.imap4service.exe.config.bak
Microsoft.Exchange.Pop3.exe.config
Microsoft.Exchange.Pop3service.exe.config.
Microsoft.Exchange.Pop3.exe.config.bak
Microsoft.Exchange.Pop3service.exe.config.bak

Resolution:

From a different (working) E2K7 SP1 environment, we could copy the above-mentioned files from the
C:\Program Files\Microsoft\Exchange Server\ClientAccess\PopImap
(this is the default location, it could also be in a different location if customer has customized it)

Restart Microsoft Exchange Transport
Attempt to start POP3 and IMAP4, if the issue persists, reapply SP1 for exchange server 2007

Advertisements

Blog at WordPress.com.